iDAN

26 Jun 2011

03.4 - Sistem Alamat dan Nama

Sistem alamat dan nama Internet amat penting diketahui untuk membolehkan Internet diguna dengan berkesan.

Alamat Protokol Internet

Setiap komputer dalam Internet mempunyai identity unik yang dipanggil sebagai alamat protokol Internet ( Internet Protocol address atau IP address ). Alamat yang unit membolehkan komputer dalam Internet berkomunikasi di antara satu sama lain dengan menghantar dan menerima data tanpa sebarang kekeliruan. Alamat IP adalah satu nombor empat bait. Nilai yang boleh diambil oleh setiap bait adlah dari 0 hingga 255. Berikut adalah beberapa contoh alamat IP.
121.16.231.7
161.142.16.62
224.171.7.80

Setiap titik disebut sebagai dot. Contohnya, 192.228.128.18 disebut sebagai 192 dot 228 dot 128 dot 18.

Pengagihan alamat IP kepada organisasi yang ingin bersambung ke Internet dilakukan oleh pihak yang bertanggungjawab menguruskannya. Di Malaysia, ia dilakukan oleh MyNIC. Organisasi yang telah menerima alamat-alamat IP ini kemudiannya boleh mengagihkan kepada ahlinya secara statik atau dinamik bergantung kepada keadaan.

Dr Ahmad Zaharim bin Abdul Aziz

03.38 - Internet Melalui Sambungan Dial Terus

Internet Melalui Sambungan Dial Terus

Bagi pengguna di rumah, sambungan ke Internet melalui Jaring atau TMNet boleh diperoleh dengan menggunakan modem dan talian telefon. Modem digunakan untuk mendail nod masukan (assces node) dan berhubung dengan modem yang terdapat pada nod masukan. Setelah sambungan diperoleh, nod masukan akan mengagihkan alamat IP bergantung kepada modem mana yang telah disambungkan. Setelah alamat IP diberi, maka komputer pengguna akan mendapat sambungan terus ke Internet . Untuk menjimatkan kos panggilan telefon, maka pengguna harus mendapatkan sambungan ke Internet dengan mendail ke nod masukan yang terdekat. Sambungan jenis ini mempunyai kerosakan dan kehilangan data yang lebih rendah kerana isyarat tidak perlu bergerak jauh untuk sampai ke komputer anda atau ke nod masukan.

Sambungan dari rumah ke nod masukan

Rajah 3.14 Sambungan dari rumah ke nod masukan

03.37 - SLIP dan PPP

SLIP dan PPP

Serial Line Internet Protocol – SLIP dan Point –to- Point Protocol –PPP adalah dua protokol yang membolehkan komputer yang menggunakan talian bersiri (serial line) seperti talian telefon berkomunikasi dengan komputer dalam Internet yang menggunakan protokol TCP/IP.

Dengan bantuan modem dan SLIP atau PPP, komputer pengguna bole disambungkan terus ke Internet melalui talian telefon. Ini membolehkan pengguna mengguna aplikasi-aplikasi Internet seperti e-mail, FTP, TELNET, Gopher dan lain-lain dari rumah.

SLIP/PPP menghubungkan komputer pengguna dengan Internet melalui talian telefon

Rajah 3.13 SLIP/PPP menghubungkan komputer pengguna dengan Internet melalui talian telefon

03.36 - Pelayan Proksi

Pelayan Proksi

Pelayan proksi diwujudkan bagi mengurangkan beban atau mengurangkan kesesakkan sesebuah talian yang menyambungkan dua rangkaian. Penggunaannya amat kritikal terutamanya bila keadaan talian sudah hamper dengan had kemampuanya.

Didalam sebuah rangkaian yang mempunyai pelayan proksi, semua komputer yang terdapat dalam rangkaian tersebut akan menghubungi proksi sebelum ia mendapatkan sesuatu dari luar rangkaian seperti fail dari pelayan FTP atau halam WWW. Jika fail atau halaman yang hendak diambil terdapat pada proksi, maka komputer yang meminta boleh mengambilnya dari proksi tanpa perlu mengambilnya dari luar rangkaian. Oleh itu, penggunaan talian ke luar rangkaian dapat dikurangkan.

Pelayan proksi mengawal penggunaan talian ke luar rangkaian

Rajah 3.12 Pelayan proksi mengawal penggunaan talian ke luar rangkaian

Sekiranya fail yang hendak diambil tidak terdapat pada pelayan proksi, maka ia akan mengambil fail tersebuit dan menyimpannya di dalam cakera keras dan menyalurkanya ke komputer yang meminta. Apabila fail yang sama diminta, proksi akan menghantar fail tersebut kepada komputer yang memintanya dan ini akan mengurangkan penggunaan sambungan ke luar.

03.35 - TCP/IP dan Komunikasi Pelanggan Pelayan

TCP/IP dan Komunikasi Pelanggan Pelayan

Semasa pelanggan dan pelayan berkomunikasi di antara satu sama lain, komunikasi berlaku dalam bentuk lapisan dengan lapisan iaitu lapisan aplikasi pelanggan akan berhubung dengan lapisan aplikasi pelayan, lapisan pengangkutan dengan lapisan pengangkutan dan seterusnya. Dalam kata lain, hanya lapisan yang sama sahaja boleh memahami antara satu sama lain.

Data yang hendak dihantar melalui Internet ke destinasinaya dipecahkan kepada unit yang lebih kecil (bungkusan) supaya komunikasi dalam rangkaian yang tersebar boleh berjalan dengan lebih lancar. Jika ada bungkusan yang rosak atau hilang, ia tidak akan menjejaskan keseluruhan komunikasi. Ia juga boleh diganti dengan mudah. Proses pemecahan data ini dilakukan sejajar dengan apa yang dikehendaki dalam melaksanakan komunikasi berasaskan teknologi pensuisan bungkusan.

Unit terkecil sebelum data ditukarkan kepada gelombang elekgromagnet untuk disalurkan ke dalam rangkaian Internet ialah datagram IP. Setiap datagram IP mempunyai alamat IP bagi komputer yang akan menerima data. IP ini akan membolehkan penghala menyalurkanya ke laluan tertentu untuk sampai ke destinasinya. Datagram IP juga mengandungi alamat IP bagi komputer yang menghantar data. Penghala yang terdapat dalam laluan datagram IP akan melihat alamat penerima yang ada pada datagram IP dan menyalurkannya ke laluan berasaskan kepda jadual laluan yang ada padanya.

Isyarat elektrik yang diterima akan ditukar kepada datagram IP dan kemudiannya ke segmen TC. TCP pula akan mengatur segmen TCP mengikut label yang ada padanya untuk membentuk data asal.

Datagram IP yang sampai tidak semestinya sampai mengikut turutan asal. Ini kerana penghala yang menyalurkan datagram IP di dalam Internet mungkin menyalurkannya ke laluan yang berbeza menyebabkan ia tidak sampai dengan turutan yang sepatutnya. Apabila IP menukar datagram IP ke segmen TCP, maka menjadi tugas TCP untuk menyusunya dalam turutan yang betul sebelum ia ditukar kepada data asal yang boleh digunakan oleh aplikasi. TCP juga memastikan komunikasi berjalan lancar. Sekiranya ada segment TCP yang rosak, TCP bagi komputer yang menerima (TCP penerima) akan meminta TCP bagi komputer yang menghantar (TCP penghantar) untuk menghantar semula segmen yang rosak itu. Jika ia lewat sampai, maka TCP penerima akan menganggap ia hilang dan akan meminta TCP penghantar untuk menghantar semula segmen yang terlibat. Jika banyak segmen yang rosak atau hilang, maka komunikasi tidak boleh berjalan lancar kerana TCP penerima akan terus meminta TCP penghantar menghantar semula segmen tersebut.

Komunikasi antara lapisan-lapisan dalam TCP/IP

Rajah 3.9 Komunikasi antara lapisan-lapisan dalam TCP/IP

Proses pemecahan data

Rajah 3.10 Proses pemecahan data

Proses penyatuan data

Rajah 3.11 Proses penyatuan data

03.34 - UDP

UDP

Walaupun berada dalam lapisan yang sama dengan TCP. UDP merupakan protokol yang tidak reliabel. UDP misalnya, tidak akan meminta komputer yang menghantar datagram IP menghantar semula data jika ia didapati rosak, hilang atau lambat diterima. UDP boleh digunakan untuk memindahkan data adalah reliabel, iaitu tidak mengalami kesesakan atau gangguan. Lazimnya hanya rangkaian yang mempunyai saiz fizikal yang kecil boleh dianggap reliabel dan denga itu boleh menggunakan UDP bagi menggantikan TCP.

UDP juga sering digunakan dalam menjayakan aplikasi yang memerlukan aliran data yang berterusan seperti aplikasi audio dan video. Di sini TCP dengan sengaja tidak digunakan kerana sikapnya yang mementingkan realibiliti sering melambatkan aliran data dan menjejaskan kelancaran video dan audio. Sebaliknya, UDP digunakan kerana ia tidak membuang masa menanti data yang hilang atau rosak.

03.33 - Protokol Kawalan Transmisi (TCP)

Protokol Kawalan Transmisi (TCP)

Penghala tidak akam mengambil tahu sama ada data sampai ke destinasinya atau tidak. Oleh itu, terpulang kepada pelanggan dan pelayan yang berada dihujung sambungan untuk memastikan data sampai dan berada dalam keadaan baik, iaiatu untuk memastikan komunikasi reliabel. Tuaga memasikan data sampai dengan baik ini dilakukan oleh protokol yang dipanggil TCP. Oleh kerana TCP menggunakan IP yang tidak reliabel, ia terpaksa menjalankan beberapa tugas tambahan bagi memastikan komunikasi berjalan dengan sempurna. Hampir kesemua aplikasi utama Internet seperti mel elektronik, FTP, TELNET dan WWW menggunakan TCP.

03.32 - Protokol Internet (IP) dan Penghala

Protokol Internet (IP) dan Penghala

IP adalah protokol yang menyalurkan datagram IP ke saluran yang tertentu dengan harapan ia sampai ke destinasinya. IP adalah protokol yang fleksibel. Ia boleh menyalurkan datagram IP ke laluan yang berbeza bergantung kepada keadaan pada laluan yang ada. Penghala yang bijak dan canggih boleh menentukan laluan yang terdekat untuk sampai ke destinasi dan sebagainya. IP dikatakan tidak reliabl kerana ia tidak mengambil tahu sama ada bungkusan komunikasi sampai ke destinasinya atau tidak. Bagaimanapun, IP adalah tunggak kepada TCP/IP kerana setiap protokol di lapisan atas dan di bawah menggunakan IP.

Penghala adalah blok binaan asas Internet. Peranti ini menggunakan IP untuk bertindak menyalurkan datagram IP yang diterima ke laluan yang tertentu supaya sampai ke destinasinya.

Apabila pelanggan berkomunikasi dengan pelayan dalam Internet, data yang dihantar oleh pelanggan akan dipecahkan menjadi bungkusan yang lebih kecil (data-gram IP) sebelum ia dihantar ke pelayan. Setiap data-gram IP mengandungi alamat IP pelanggan dan pelayan. Semasa dalam laluan ke pelayan, penghala akan memeriksa alamat IP yang terdapat pada setiap datagram IP yang diterimanya sebelum ia disalurkannya ke laluan yang sesuai. Datagram IP yang diterima oleh pelayan akan dicantumkan semula oleh TCP/IP pelayan dan TCP pelayan akan memeriksa data yang diterima bagi memastikan tiada yang hilang dan sebagainya.

Penghala menggunakan jadual laluan bagi menentukan laluan setiap bungkusan

Rajah. 3.7 Penghala menggunakan jadual laluan bagi menentukan laluan setiap bungkusan.

Dalam kes di mana terdapat dua laluan ke destinasi yang sama, penghala adakalanya diberi kebenaran untuk menentukan laluan yang sesuai untuk menyalurkan data ke destinasinya. Kelonggaran ini penting bagi memastikan data masih dapat dihantar ke destinasinya sekiranya terdapat laluan yang rosak.

Rajah 3.8 Data daripada sebuah komputer yang sedang berkomunikasi dengan komputer lain akan merentasi banyak nod (hos, get laluan atau penghala) sebelum sampai kedestinasinya

03.31 - Protokol-protokol Utama dalam TCP/IP

Protokol-protokol Utama dalam TCP/IP

TCP/IP merupakan gabungan beberapa protokol. TCP/IP berfungsi dengan bantuan protokol-protokol lain yang menjalankan fungsi yang khusus di lapisan komunikasi yang berbeza-beza.

Setiap protokol dalam TCP/IP dianggap sebagai satu modul bebas yang mempunyai peranannya yang tersendiri. Dengan menggunakan konsep modul ini, maka ciri-ciri fleksibel dan reliable yang diperlukan oleh TCP/IP boleh dilaksanakan dengan mudah.

Perkaitan di antara protokol-protokol di TCP/IP

Rajah 3.6 Perkaitan di antara protokol-protokol di TCP/IP

Semua protokol dalam TCP/IP adalah penting, tetapi yang terpenting adalah TCP dan IP. TCP memastikan komunikasi berjalan dengan baik dan bungkusan komunikasi yang dihantar sampai tanpa sebarang kerosakan. IP pula adalah protokol yang digunakan oleh semua protokol yang di atasnya untuk menyalurkan bungkusan komunikasi (datagram IP) ke destinasinya. Dengan itu, ia menjadi tunggak kepada TCP/IP. IP tidak memastikan sama ada bungkusan sampai ke destinasinya atau tidak. Ia cuma menyalurkan bungkusan ke laluan yang seterusnya dengan harapan ia sampai. Ataupun dengan kata lain, TCP membekalkan TCP/IP dengan ciri-ciri reliable yang diperlukan. IP pula memberikannya kefleksibelan dalam menghantar bungkusan komunikasi. Itulah sebabnya TCP/IP dinamakan dengan protokol TCP dan IP. Fungsi beberapa protokol utama dalam TCP/IP ditakrifkan dalam jadual berikut.

Protokol-protokol Utama dalam Lapisan Pengangkutan

Protokol Fungsi Rujukan
TCP Transmission Control Protocol adalah protokol yang membolehkan aliran data secara dua hala, memastikan data sampai dengan selamat dan betul dan mengawal pengaliran data di antara dua hos. RFC 793
UDP User Datagram Protocol adalah protokol yang menghantar data ke sesebuah hos tanpa menghiraukan sama ada data itu sampai atau tidak. UDP tidak reliabel seperti TCP. RFC 768

Protokol-protokol Utama dalam Lapisan Aplikasi

Protokol Fungsi Rujukan
SMTP Simple Mail Transfer Protocol adalah protokol yang menyatakan bagaimana sebuah hos menghantar e-mail ke hos lain, iaitu bagaimana penghantar dan penerima harus berkomunikasi semasa penghantaran e-mail. RFC 821

RFC 822

TELNET Protokol yang membolehkan sebuah hos disambungkan ke sebuah hos multi-pengguna sebagai terminal RFC 854
FTP File Transfer Protocol adalah protokol yang menyatakan bagaimana fail harus dipindahkan dari satu hos ke hos lain. RFC 959
TFTP Trivial File Transfer Protocol adalah protokol yang pada asasnya sama seperti TP tetapi tidak reliabel seperti FTP. RFC 1350

Protokol-protokol Utama dalam Lapisan Rangkaian

Protokol Fungsi Rujukan
IP Internet Protocol adalah protokol yang menyatakan bagaimana datagram IP harus dibina dan bagaimana datagram IP disalurkan dari satu hos ke hos yang lain sehingga sampai ke destinasinya. IP memahami mesej ralat dan kawalan yang dihasilkan oleh ICMP. RFC 791
ICMP Internet Control Message Protocol adalah protokol yang boleh digunakan bagi melaporkan masalah yang berkaitan dengan penghantaran datagram IP ke hos yang menghantarnya seperti pembuangan datagram IP semasa berlaku kesesakan. ICMP sering dianggap sebagai sebahagian dari IP RFC 792
IGMP Internet Group Management Protocol adalah protokol yang digunakan oleh hos dan penghala yang menyokong system multicasting untuk menyatakan keahlian kumpulan multicast. RFC 1112

Protokol-protokol Utama dalam Lapisan Fizikal

Protokol
Fungsi
Rujukan
ARP
Address Resolution Protocol adalah protokol yang mengikat alamat fizikal kad rangkaian dengan alamat logical yang dipanggil alamat IP.
RFC 826
RARP
Reverse Address Resolution Protocoladalah protokol yang digunakan oleh sesebuah hos untuk mendapatkan alamat IP daripada hos lain berdasarkan alamat fizikal yang ada padanya. Ia lazimnya digunakan oleh hos yang tidak mempunyai cakera keras untuk menyimpan alamat IP.
RFC 903

03.3 - Bahasa Komunikasi

TCP/IP merupakan bahasa dan tatacara komunikasi (protokol) yang digunakan oleh komputer yang terdapat dalam Internet. Protokol ini digunakan untuk berkomunikasi di antara satu sama lain. Bukan itu sahaja, perkakasan rangkaian yang membentuk rangkaian Internet seperti penghala juga memahami TCP/IP.

Lapisan Komunikasi TCP/IP
Jika dilihat dalam konteks model komunikasi, TCP/IP merupakan protokol yang dibina berasaskan kepada model komunikasi empat lapisan. Setiap lapisan TCP/IP mempunyai peranan dan fungsinya yang tersendiri.

Lapisan yang teratas adalah lapisan aplikasi. Perisian e-mail dan perisian FTP berfungsi di lapisan ini. Di bawah lapisan aplikasi adalah pengangkutan. Ia bertanggungjawab mengawal pengaliran data dan kesahihan data. Jika terdapat kesesakan dalam rangkaian, maka lapisan ini akan cuba melambatkan pengaliran data supaya kesesakan dapat dikurangkan.

Lapisan komunikasi TCP/IP dan fungsinya

Rajah. 3.5 Lapisan komunikasi TCP/IP dan fungsinya.

Dibawah lapisan pengangkutan pula adalah lapisan rangkaian. Lapisan ini Cuma berfungsi menyalurkan data ke laluan yang telah ditentukan berdasarkan kepada destinasi data. Lapisan yang terbawah sekali ialah lapisan fizikal. Lapisan ini bertanggungjawab menukarkan data yang hendak dihantar ke destinasinya kepada isyarat elektronik untuk disalurkan melalui talian tembaga, gentian optik dan sebagainya.

Prasarana Rangkaian

Rangkaian fizikal merupakan asas kepada segalanya. Tanpa rangkaian fizikal, Internet tidak boleh wujud. Rangkaian Internet, seperti mana-mana rangkaian yang lain, dibina dengan menggabungkan perkakasan asas rangkaian yang terdiri daripada pengulang, jambatan, penghala dan get laluan. Perkakasan ini membentuk lebuh raya maklumat apabila ia disambungkan di antaranya bagi membolehkan hos-hos berkomunikasi.

Rangkaian Kawasan Setempat

Rangkaian dan komponen-komponen asas rangkaian

Rajah 3.1 Rangkaian dan komponen-komponen asas rangkaian.

Rangkaian Kawasan setempat (Local Area Network-LAN ) adalah rangkaian komputer yang dibina meliputi satu kawasan kerja yang kecil seperti dalam satu ruang pejabat atau bangunan yang sama. Di dalam LAN, seperti rangkaian A1, A2 dan A3 (Rajah 3.1), komputer yang membentuk rangkaian boleh disambungkan di antara satu sama lain secara langsung dengan menggunakan kad antaramuka rangkaian yang dimasukkan ke dalam slot tambahan yang terdapat dalam computer. Rangkaian yang sedemikian mempunyai saiz fizikal yang terhad kerana komputer dalam rangkaian tidak boleh melebihi jarak maksimum yang di tetapkan. Jika rangkaian seperti ini perlu dibina bagi meliputi satu kawasan yang luas, seperti rangkaian A2 (Rajah 3.1), maka pengulang perlu digunakan untuk menyambungkan dua bahagian atau segmen yang berjauhan di dalam rangkaian yang sama.

Dua rangkaian bebas, dekat atau jauh, boleh di sambungkan di antara satu sama lain bagi membentuk sebuah LAN yang lebih besar dengan menggunakan jambatan seperti yang dilakukan pada rangkaian A1, dan A2 (Rajah 3.1). Jambatan berbeza daripada pengulang kerana ia boleh menyambungkan dua LAN yang berasingan manakala pengulang pula hanya menyambungkan dua bahagian LAN yang sama yang berada jauh di antara satu sama lain.

Membina Rangkaian

Dua rangkaian bebas juga boleh disambungkan di antara satu sama lain dengan menggunakan penghala seperti yang dilakukan pada rangkan A dan C, B dan C serta C dan D (Rajah3.1). Penghala lazimnya digunakan untuk menyambungkan rangkaian-rangkaian yang lebih besari dikenali sebagai rangkaian kawasan luas (Wide Area Network –WAN). Penghala berbeza daripda jambatan kerana kebolehannya menyambungkan dua rangkaian bebas melalui talian yang menggunakan protokol komunikasi yang berbesa daripada protokol rangkaian.

Penghala merupakan komponen rangkaian yang sangat penting dalam Internet kerana ia adalah perkakasan yang menyambungkan rangkaian di antara satu sama lain bagi membentuk rangkaian Internet yang sangat besar. Sambungan di antara satu penghala dengan penghala yang lain boleh dianggap sebagai satu laluan. Oleh itu, sebuah penghala yang disambungkan ke dua penghala yang berasingan mempunyai dua laluan yang berasingan. Apabila dua komputer dalam Internet berkomunikasi di antara satu sama lain maka lazimnya bungkusan komunikasi dari kedua-dua buah komputer akan dihantar oleh penghala-penghala yang terlibat dari satu laluan ke laluan yang lain sehingga ia sampai ke destinasinya. Jumlah laluan (hop) dari satu penghala ke penghala yang lain ini bergantung kepada bilangan rangkaian yang terdapat di antara kedua buah komputer tersebut. Jika mana-mana satu daripada penghala yang terlibat tidak menghantar bungkusan komunikasi ke laluan yang betul, maka bungkusan tidak akan sampai ke destinasinya. Dengan itu dua komputer yang terlibat tidak boleh berkomunikasi.

Adakalanya rangkaian tersebut perlu disambung dengan menggunakan bahasa komunikasi yang berbeza-beza. Oleh yang demikian, penghala yang digunakan mesti boleh memahami dan menterjemahkan bahasa-bahasa komunikasi yang digunakan. Penghala yang sedemikian dipanggil get laluan (gateway).

03.2 - Konsep Komunikasi Antara Komputer

Mekanisma Asas Komunikasi

Secara amnya, proses menjayakan sesuatu komunikasi boleh dipecahkan kepada sekurang-kurangnya tiga lapisan di mana setiap lapisan memainkan peranan yang berbeza. Dalam konteks komunikasi di antara manusia, peranan lapisan ini boleh dilihat seperti berikut: Manusia , memikirkan sesuatu idea yang mudah, yang abstrak dan kompleks di dalam pemikirannya. Pemikiran manusia ini boleh dianggap sebagai satu lapisan komunikasi yang dipanggil lapisan kogniti. Idea ini jika hendak disampaikan kepada pendengar perlu disampaikan dalam bahawa yang boleh difahami oleh pendengar. Proses menukar idea kepada bahasa yang boleh difahami ini merupakan tugas lapisan bahasa. Untuk menyampaikan idea yang telah diatur dalam bahasa yang boleh difahami oleh pendengar, maka bunyi bagi setiap perkataan dalam bahasa yang ingin digunakan perlu dihasilkan. Proses menghasilkan bunyi ini dilakukan oleh tekak, iaitu lapisan pemancar. Pada keseluruhannya proses menyampaikan sesuatu idea kepada pendengar melibatkan beberapa proses yang bergerak dari lapisan atas ke lapisan bawah.

Lapisan komunikasi dan fungsinya
Rajah 3.2 Lapisan komunikasi dan fungsinya

Bagi pendengar, proses memahami sesuatu idea yang disampaikan kepadanya melibatkan pergerakan dari lapisan bawah ke lapisan atas.Bunyi yang diterima oleh telinga pendengar (lapisan penerima) ditukarkan kepada perkataan untuk diproses oleh lapisan bahasa bagi membentuk ayat-ayat yang difahami. Daripada ayat-ayat ini barulah idea yang disampaikan oleh penyampai boleh difahami oleh penerima. Idea yang diterima ini kemudian boleh diolah dan diubah bagi menghasilkan idea-idea yang baru. Proses ini dilakukan oleh lapisan kognitif. Lapisan Kognitif, bahasa dan pemancar/ penerima boleh berfungsi dengan bebas tanpa mempengaruhi antara satu sama lain.Kerosakan pada lapisan kognitif tidak akan menjejaskan fungsi lapisan bahasa atau lapisan pemancar/penerima secara langsung. Contohnya, orang yang tidak sempurna pemikirannya masih boleh menghasilkan perkataan bagi membentuk ayat dan seterusnya menghasilkan bunyi. Ini menunjukkan bahawa lapisan kognitif yang tidak sempurna tidak menjejaskan operasi lapisan lain. Cuma kemungkinan besar ayat yang ditutur itu tidak sempurna maknanya. Begitulah juga halnya dengan orang yang pekak boleh berfikir dan membentuk perkataan serta ayat dengan baik walaupun dia tidak boleh mendengar.

Model Komunikasi Pelanggan-Pelayan

Model komunikasi merujuk kepada tatacara di mana dua buah komputer berinteraksi di antara satu sama lain bagi menjalankan sesuatu tugas. Di dalam Internet, perjalanan setiap aplikasi Internet adalah berasaskan kepada model komunikasi yang dipanggil komunikasi pelanggan-pelayan (client-server communication). Di sini, pelanggan (client) merupakan perisian yang meminta sesuatu perkhidmatan manakala perisian yang memberikan perkhidmatan dipanggil pelayan (server). Lazimnya komputer yang menjalankan perisian pelanggan dipanggil sebagai pelanggan. Begitulah juga bagi komputer yang menjalankan perisian pelayan dipanggil sebagai pelayan. Oleh itu, perkataan pelanggan dan pelayan boleh merujuk kepada perisian atau komputer yang menjalankan perisian tersebut. Aplikasi yang menggunakan konsep komunikasi pelanggan-pelayan dipanggil sebagai aplikasi pelanggan-pelayan (client-server application). Perjalanan aplikasi ini dikawal oleh pelanggan. Apabila pelanggan membuat sesuatu permintaan maka pelayan akan bertindak melayan permintaan pelanggan. Contohnya, dalam aplikasi pemindahan fail FTP, perjalanan aplikasi lazimnya bermula dengan pelanggan meminta pelayan menghantar fail kepadanya. Apabila pelayan menerima arahan daripada pelanggan maka ia akan bertindak serta merta menghantar fail yang diminta oleh pelanggan.
Model komunikasi pelanggan-pelayan
Rajah 3.3 Model komunikasi pelanggan-pelayan
Komunikasi pelayan-pelayan dalam aplikasi pemindahan fail

Rajah 3.4 Komunikasi pelanggan-pelayan dalam aplikasi pemindahan fail

Pelayan yang baik adalah pelayan yang boleh melayani permintaan pelanggan setiap masa. Oleh yang demikian, komputer yang menjadi pelayan di dalam Internet adalah komputer yang beroperasi selama 24 jam sehari , 7 hari seminggu dan 365 hari setahun. Komunikasi pelanggan-pelayan membolehkan beban dan tugas menjalankan sesebuah aplikasi dikongsi bersama. Ini dapat mengurangkan kesesakan komunikasi dan mengimbangkan penggunaan kuasa sesebuah komputer

Bagaimana Internet berfungsi

Bagaimana Internet berfungsi

Membina sebuah rangkaian yang besar bukanlah satu tugas yang mudah. Namun begitu, Internet yang direka berasaskan konsep komunikasi tahun 60-an dan dibina menggunakan protokol dan teknologi tahun 70-an telah berjaya menyambungkan berjuta-juta komputer dari beribu-ribu rangkaian di dunia tanpa sebarang masalah yang besar.

Dalam Tapak 2, pembaca sudah mengetahui konsep-konsep yang digunakan untuk membina rangkaian Internet dan protokolnya. Dalam tapak ini, pembaca akan didedahkan dengan lebih mendalam lagi tentang bagaimana Internet itu beroperasi supaya pengetahuan mengenainya dapat membantu penggunaan Internet dengan lebih berkesan. Semoga pembaca juga dapat melihat bahawa sesuatu yang canggih seperti Internet boleh dibina dengan menggunakan konsep-konsep logikal yang mudah.